Obsidian Git - Android - Authentication failed

What I’m trying to do

I’m trying clone my vault github repo in order to use it by my android phone and push all changes.

What I’ve done until now:

  • I’ve already uploaded my vault as repo on github (where I push changes by my laptop).
  • I’ve downloaded Termux on Android.
  • I’ve cloned the repo on my phone using Termux.
  • I’ve opened the repo folder ad vault with Obsidian android app.
  • I’ve updatet github credentials from git plugins settings (according to the plugin suggestion, I’m not able to see the password even if I’ve entered github username and password both).

Since I’ve already installed git plugin it try to pull changes from github repo as soon as I run the Obsidian application, but every time (even if I manually run git pull from obsidian command palette) a banner tell me that

“Authentication failed. Please try with different credentials.”

I’ve already looked for other thread but I’ve found nothing helpfull for my specific case.

Any ideas?
If more specific information are required, I’ll provide them!

Thanks in advance,

Instead of using you github password, you need to use a “personal access token” generated for your account on that repository.

You can find instructions online on how to generate it. This means your password to your entire github account is not at risk when you cache credentials, etc. A hassle but a great thing for security.

1 Like

Thank you, it worked! Just for those who come, you have to insert the access token in git hub settings. I’ve tried to click on error banner I’ve spoken about, who opens a user and password fields, and insert my access token there… It didn’t worked.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.