Obsidian file completely freeze my computer

Hi everyone I have a problem in my computer which has been going on for a few days, I wish u guys help me

Steps to reproduce

Start Obsidian and start navigating between my md files (at the begining thought it was a problem of a specific file I delete it but the problem continues)

Expected result

Navegate without problem in my vault

Actual result

After about 2 minutes obsidian freezes and u can’t change the file or open the settings, nothing.
After few seconds u can’t do anything in the computer, this problem freezes all include the keyboard because can’t shutdown or open the task manager.
The only solution is force shutdown manually.


  • Operating system: Windows 11
  • Obsidian version: 0.12.19

Additional information

I try to reinstall Obsidian from my computer, delete the file wich I tought was the problem, update windows version, disable the hardware acceleration but nothing works the problem persists

1 Like

Can you try opening the Task Manager, and watching if anything strange happens there?

This sounds like it could be a memory-leak, where your RAM usage goes up and up, until all of your apps become unresponsive.

  1. How much RAM do you have in your computer?
  2. You said version 0.12.19. What is your installer version, also?

Another question: where is your vault? Like, where did you create it? What are you including in it?

I faced the same issue twice today. But in my case the system became responsive by itself after a minute or two.

OS windows 11

Obsidian ver 0.12.19

Hi there, finally I solved my problem.

It seems that the problem was on Google Drive. I use the cloud service to backup all my vault. How did I find out?

Well, I wait like 10 minutes (after Obsidian freezes my computer), and then it begins to work again, after that Google Drive show a message: “error while syncing a file (the file which gives me the problem)”

So yeah, the problem was my cloud service, I changed a Google Drive preference (save the files in the computer and cloud) after that and solved the problem.

Thank you guys for your help.

1 Like

It had been set to stream files from the web instead of having them local?

1 Like

Yes, but I don’t know why that preference produce the problem because in the file explorer I select the option to keep all Google Drive files offline

That’s interesting, and I don’t know either.
I simply try to stay abreast of the detail of the problems and solutions for the various sync services.
It looks as if the first option to check with any freezing problem is the sync service and its settings. And maybe then a particular file it might be choking on.
Unless its iCloud when I’ve not seen anyone come near rhyme or reason for its behaviour.

1 Like

I’m having a similar performance issue but am not using Google Drive to sync my vault but do use Google drive for other things. Also, to clarify are you using Google Backup and Sync or the new Google Drive app?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.