Obsidian emptied my note

Hi, I was using obsidian when I noticed my system resources were high. I finished writing the system and used Command-Q (on MacOS) to quit the app (and all other apps). I subsequently reopened obsidian (straight away) but the note was completely empty. I checked trash and file recovery but they don’t have the note I was working on. All links to the note are gone as well. It’s like the note was just emptied to blank?

I really need this note back, is there any way I can recover it? Is it just some corruption?

Things I have tried

File recovery, the latest snapshot was 6 days ago which is not very useful at all.

What I’m trying to do

Recover my note in full!

Try File recovery plugin

Thank you so much, it worked! I tried to do file recovery straight way from the Command-P menu and it only came up with one snapshot five days ago. When I tried it from settings though it came up with all the snapshots. (This behaviour with only one snapshot from Command-P is still the case).

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.