Obsidian doesn’t use default browser on macOS (v12)

Apologies if this is considered duplicate. Basically same as described in Obsidian doesn’t use default browser on Ubuntu 22.04… but given the thread, seemed like it should be broken out here for macOS.

Steps to reproduce

copy http link to note; click to open.

Did you follow the troubleshooting guide? [Y/N]

Yes. Same behavior in sandbox vault

Expected result

Open with the OS-designated default browser (e.g. Brave)

Actual result

Opens with a different browser. (Safari… the factory-default browser. Not sure if relevant)


Obsidian version: v1.5.12
Installer version: v1.4.13
Operating system: Darwin Kernel Version 21.6.0: Thu Nov 9 00:38:19 PST 2023; root:xnu-8020.240.18.705.10~1/RELEASE_X86_64 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


macOS v12.7.2 (21G1974)

Many thanks in advance.

Because of macOS v12.7.2 and Electron support, I’m assuming you can’t use a newer installer beyond v1.4.13?

According to What version of Obsidian is compatible with OSX 10.13.6? - #2 by holroy it looks like macOS 10.13.x and Obsidian installer v1.5.3 can work together. As you’re using macOS v12.7.2, installer 1.4.13 or 1.4.16 may be the last you can use.

With the older versions of both macOS and Obsidian, I don’t know if the team will spend much time on this or even be able to test it out.

Beyond the Ubuntu link you found, did anything else bubble up specific to macOS in the older posts? There may be something if you dig a bit more.

I’m not really sure how to determine which installer I’m using? I had thought I was on the most recent release, installing with just the mac dmg.

But to your point, if it’s an issue with interaction with a much older OS, understandable it might not be top priority. Will hunt around more in case anyone found workarounds.


In Settings > General, the installer version is the line right under the current version at the top.

Sorry, I mean where would I find an alternative installer and how would I determine if I could use it?

Going off of:

I’m assuming you can’t use a newer installer beyond v1.4.13?

I’m not sure how to determine this.


Yeah, from your original debug info:

The releases are all here: https://github.com/obsidianmd/obsidian-releases/releases. Scroll down to 1.4.16 and click the “Assets” dropdown. You want the -universal.dmg version (for mac).

Once downloaded and the DMG opened, you can drag the installer to your desktop to test it. With your original Obsidian closed, try to open 1.4.16. If it opens, you’re good to go and can move that to /Applications. I’m guessing the 1.5.3 installer (and later) won’t open.

You’ll still be able to use Obsidian v1.5.12 and (probably) future updates for the time being — you just can’t update the installer anymore.

Also, I don’t know if an older version is causing the issue or not, but I reckon it’s going to be hard to test if that’s the case or not.

Hmm, Ok, well I tried downloading the 1.4.16 and copied to desktop. I can open, but then it appears to still be opening 1.5.12?

Though admittedly I’m still not really sure what I’m verifying. Am I trying to downgrade in this scenario? I guess I’m not following whether the earlier Obsidian version somehow has a later installer version? That would seem odd.

Yes, that looks correct.

The installer version is what Obsidian.app is. Your Obsidian version can be the same or later. In this case it’s 1.5.12. That’s stored in a different place, and you’ll be able to update that in-app for the time being.

The goal here is not downgrading, but finding the most recent installer version that will work with macOS v12.7.2.