Obsidian Crashing when using quick switcher

Steps to reproduce

  1. Use quick switcher once and open a markdown file
  2. When in this document open the quick switcher again, and use the arrows keys to navigate

Expected result

The quick switcher navigates through documents as I press the arrow keys

Actual result

Obsidian freezes and has to be restarted


  • Operating system: Windows 10 v. 2004
  • Obsidian version: v.0.11.0

Please, post a screen recording.

obsidan_crashing.zip (939.3 KB)

In the screen recording the second time I open the quick switcher i press the down arrow once, which leads to obsidian freezing. I can still move and resize the window but cannot interact with it or close it.

I can’t repro. do you have plugins installed? did you bing some custom shortcuts?

Nope, that was in a new vault in safe mode and no custom shortcuts.

where are your files stored? what is your installer version?

I have tried with files stored on onedrive and in my documents folder and both had the same effect when using quick switcher, and my installer version is 0.11.0

can you please keep the console open (ctrl-shift-i) and record what happens and if something is reported?

I recreated the issue and preserved the logs but there where no errors, the only thing that was reported was in codemirror.js :
[Violation] Added non-passive event listener to a scroll-blocking ‘touchstart’ event. Consider marking event handler as ‘passive’ to make the page more responsive. See Passive event listeners - Chrome Platform Status

I have noticed that after obsidian freezes if you press ctrl +o again it will then reopen a new quick switcher which works normally, but while frozen no other hotkeys seem to work

thank you.

Just tested and ctrl + o crashes teams and discord as well so seems like an issue with electron not Obsidian

this is an issue specific to your computer. We aren’t able to reproduce it. Let me know if you figure it out.

Did you ever solve this? I’m having the same issue.

I was using the beta version of Microsoft edge, and changing that to a different default browser fixed it, but I’m not sure if that was the problem or was just changing something that helped.