Obsidian Community Plugins not opening

Hey guys, I don’t know since when this problem has been underlying, but just recently when trying to install a new plugin, I realised that my community plugins section was not opening no matter what I tried, error: “Failed to load community plugins”. Everything related to sync seems to be not working, my Zotero integration using Citations plugin is also non-functioning, if I try to check for updates (of Obsidian and community plugins) that too gets stuck forever etc.

Things I tried:

  1. Restarting my laptop (MacOS, Sonoma)
  2. Uninstalling and reinstalling Obsidian
  3. Uninstalling and reinstalling Zotero
  4. Tried almost every fix mentioned in the forums, including using VPNs (yes, I am from India as well, like some previous users mentioning the same issue).
  5. I even tried using a completely different vault, didn’t work.
  6. I have also tried flushing my DNS, didn’t work either.

I hope there is some fix to this. It’s been days, and I’m already on the verge of switching to some PKM system as I reply quite heavily on daily PKM use. If there is no solution yet, would really appreciate some suggestions apart from Logseq :slight_smile:

Thank you!

Are you able to access this link in your browser?

https://raw.githubusercontent.com/obsidianmd/obsidian-releases/master/community-plugins.json

You mentioned using a VPN and flushing DNS, but did you try changing your DNS servers to 1.1.1.1 or 8.8.8.8 or something else?

Hi! The problem is now fixed, both the Zotero integration and the non-working of other community plugins.

Fix (thanks to your suggestion): I changed my DNS server to 1.1.1.1, once that worked, I didn’t bother with the 8.8.8.8 one.

The link of “raw.githubusercontent.com…” was not opening before the change, now it just shows a lot of code (I hope that’s what its meant to be showing).

Thanks for the help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.