Obsidian and latte-dock - EMFILE error

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

Have both Obsidian and latte-dock installed
Launch latte-dock then Obsidian

Expected result

Obsidian opens.

Actual result

“EMFILE: too many open files”

Environment

  • Operating system: Ubuntu 20.04
  • Obsidian version: 0.11.5

search the forum for the error you got

Unless I misunderstood the instructions the issue persists even if increasing the file-max:

image

If I have not misunderstood please re-open the issue.

I am gonna move this to help and hope somebody can help us figure out exactly what the problem is. This is unfortunately too much of niche issue and I am not even sure we are doing something wrong here.

1 Like

Thank you. Aye, I do suspect Latte-Dock may be responsible as so far no other software running at the same time has caused this issue. I’ll open an issue on their GitHub as well.

I’m having this issue on 1st launch of the App after creating a Vault from scratch, there’s no way there are too many files in the vault.

Also, I’ve checked the file limits above and had the same output as @Abe

My vault path is not short /home/sam/Dropbox/sam/RefInfoPIM/ObsidianNotes ← is this any potential issue ?

Obsidian 0.13.19 under Ubuntu 20.04

TIA for any assistance.

Strangely enough… a logoff then a logon… and I could open the freshly created vault just fine…

I wonder what might have happened

Having the same issue here. Fresh install.

System: Ubuntu 21.04
File system: ZFS
file-max: 9223372036854775807
Home directory in a different partition:

→ zfs list|grep home
tank/data/home       773G  66.7G      244G  /data/home

I downloaded and installed the .deb package and then ran:

→ obsidian 
2022-03-09 11:59:32 Loading main app package /opt/Obsidian/resources/obsidian.asar
[2155504:0309/075932.803325:ERROR:proxy_config_service_linux.cc(614)] inotify_init failed: Too many open files (24)
[2155504:0309/075932.803466:ERROR:file_path_watcher_linux.cc(321)] inotify_init() failed: Too many open files (24)
[2155504:0309/075932.817086:ERROR:proxy_config_service_linux.cc(614)] inotify_init failed: Too many open files (24)
[2155564:0309/075932.842842:ERROR:file_path_watcher_linux.cc(321)] inotify_init() failed: Too many open files (24)
Error: unrecognized flag --always_compact
Try --help for options
2022-03-09 11:59:32 Checking for update using Github
2022-03-09 11:59:33 Success.
2022-03-09 11:59:33 Latest version is 0.13.31
2022-03-09 11:59:33 App is up to date.

Both trying to open the help or creating a new vault result in the application crashing with the following:

Error: EMFILE: too many open file

I deleted ~/.config/obsidian and downloaded the AppImage, with the same results:

→ ./Obsidian-0.13.31.AppImage 
2022-03-09 12:01:39 Loading main app package /tmp/.mount_ObsidiQ66TKY/resources/obsidian.asar
[2157427:0309/080140.249380:ERROR:proxy_config_service_linux.cc(614)] inotify_init failed: Too many open files (24)
[2157427:0309/080140.254706:ERROR:file_path_watcher_linux.cc(321)] inotify_init() failed: Too many open files (24)
[2157427:0309/080140.403231:ERROR:proxy_config_service_linux.cc(614)] inotify_init failed: Too many open files (24)
2022-03-09 12:01:40 Checking for update using Github
[2157616:0309/080140.546633:ERROR:file_path_watcher_linux.cc(321)] inotify_init() failed: Too many open files (24)
Error: unrecognized flag --always_compact
Try --help for options
2022-03-09 12:01:40 Success.
2022-03-09 12:01:40 Latest version is 0.13.31
2022-03-09 12:01:40 App is up to date.

I don’t have issues with any other applications, including VSCode, which is also constantly watching the filesystem.

I tried to add the “–help” flag to see if there is a debug option, but nothing different happens.

Thanks.

Replying to self. I was able to fix this by changing the following:

# echo 1024 > /proc/sys/fs/inotify/max_user_instances
1 Like