Obsidian 0.14.4 regressions when opening vault

Steps to reproduce

When using a formerly working url to open specific vault, worked for a long time, now:
Unable to find a vault for the URL obsidian://open?vault=tibworkspace&file=WORKSPACE

Note the vault is on an SSD drive.

Also each time when starting Obsidian it asks to turn off safe mode and asks for live preview update. Before this was asked only once and then the setting was remembered.

Expected result

a) open a vault with open url
b) not prompt for safe mode every timr
c) not ask to turn on live preview (off always for me)

Actual result

a) can’t find vault
b) asks for safe mode every time Obsidian is launched
c) asks for live preview update every time Obsidian is launched.


  • Operating system:
    MacOSX 11.16.4.
  • Debug info:

Obsidian version: v0.14.2
Installer version: v0.14.2
Operating system: Darwin Kernel Version 20.6.0: Wed Jan 12 22:22:42 PST 2022; root:xnu-7195.141.19~2/RELEASE_X86_64 20.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: on
Base theme: light
Community theme: Atom-ks
Snippets enabled: 1
Safe mode: on

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.

Additional information

This could also be a corruption in the .obsidian folder of some kind… Indexing is done each and every time this folder is opened…

Well, of some reason I had the previous Obsidian running in the background, the open URL opened both, don’t know why, but that’s why they both battled about possible shared resources somewhere, prefs files… Anyway, works fine now, I deleted the previous Obsidian – usually keep the previous one around in case a new update causes issues.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.