Obsdian helper CPU hitting 100-200% upon startup

Env:

  1. M1 Mac

Things I have tried

  1. Tried to delete some of the plugins

What I’m trying to do

I am simply trying to startup Obsidian. Please advise !

Improve Obsidian Startup Time on Older Devices with the FastStart Script (substack.com)
Hope this article could help you!

You say some plugins, but you need to try it with no plugins.

  • If you can get to the main Obsidian window, open settings and turn on restricted mode (Community Plugins > Restricted mode). Does it seem OK? If so, turn off restricted mode and turn off all plugins. Restart Obsidian. Turn them on one-by one. If you have a lot, divide and conquer, can help.

  • If you can’t get to the main window, with Obsidian closed, try moving your .obsidian folder to your desktop (or somewhere safe) and starting. How’s it behave then? (.obsidian has all your settings, themes, plugins, etc, so it will be like starting fresh - but all your notes will be fine)

1 Like