Numbered lists don't indent properly with 3 or more digits

Steps to reproduce

Paste the following into Obsidian:

7. Thought
8. Thought
	1. Sub (1 Tab)
	2. Sub (1 Tab)
9. Thought

***

777. Thought
778. Thought
	1. Sub (1 Tab)
	2. Sub (1 Tab)
779. Thought

***

777. Thought
778. Thought
		1. Sub (2 Tabs)
		2. Sub (2 Tabs)
779. Thought

Expected result

The “Sub”-items in the second list should be displayed as sub items in the list in preview mode (778. a) 778. b)), since they are indented with one tab like the items in the first list.

Actual result

They are treated as a continuation of the list, so the first sub element becomes 779 instead of 778.a. So lists with numbers with 3 or more digits don’t work as expected.

If I set the number of spaces for one tab to 8 in the settings, the problem is solved. But it can still be considered a bug that the edit mode makes you think it works with 4 spaces.

Environment

macOS 11.4
Insider build 0.12.18


Additional information

This is not a bug but the way markdown works.