Numberd checkmarks not preserved when changing indentation

tested in sandbox. (also, disabling smart indent lists doesn’t work in sandbox…)

Steps to reproduce

1. item without a todo
\t1. [ ] item with a todo. Here you'll shift-tab to remove the indent (the main bug). You'll need to tab this to add it, and you'll notice: tabbing a numbered item removes the checkmark!
8. [ ] another todo item. this one gets the checkmark removed during list reordering
\t4.  [ ] another todo item. this one is preserved. slight difference: there are two spaces before the checkmark. However, community plugins like checklist don't recognize -\s\s[, only -\s[
- [ ] usually this continues all the way down the list (very annoying), but not always. this bullet item isn't a number, and thus isn't affected.

Expected result

numbered items with checkmarks after them should preserve their checkmarks, during indent or remove indent. This shouldn’t require two spaces. after removing the tabs (or after re-adding them), the todo items should still remain.

Actual result

the todos/checkmarks are removed (possibly a bug in smart-tabs?)


  • Operating system: Linux (Pop OS)
  • Debug info:
    Obsidian version: v1.1.9
    Installer version: v0.15.9
    Operating system: #202212290932~1673966427~22.04~e15d5b5 SMP PREEMPT_DYNAMIC Tue J 6.0.12-76060006-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on


Additional information

I think obsidian is neat. What are your thoughts about this bug?

importantly I’m not talking about the numbers themselves. I know smart-indent will correct the number on the list to be the number before it plus 1 (not correct the whole list) - this bug is about checklists.

I don’t think numbered task lists are supported (tho that behavior still surprises me).

I am not sure I follow you. Post a screen recording of this happening in the sandbox vault.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.