Note lost after crash

We strongly recommend you to search the forum with possible keywords before submitting a new bug report.

Please also try your repro steps with restricted mode on (community plugins disabled), default theme and no custom CSS snippets, restart Obsidian, and see if it’s still reproducible.
On Desktop, you can use the Sandbox vault (lower left corner ? → Open Sandbox vault).

If it’s an issue with third-party plugins or themes, try contacting the author for help.

Mobile-specific bug reports should be filed here:

Once you’ve done the above, delete everything above this line.

Steps to reproduce

Random crash once a week or so. On startup nothing is lost. Today there was a crash and the whole 900KB file was gone, ie down to 0 bytes but still there as an empty file.

Expected result

I expect a restart and have my note still there, with maybe a few characters missing from the last edit. After the crash the file was set to 0 bytes.

Actual result


  • Operating system:
windows 11 current update.
  • Debug info:

Obsidian version: v1.1.16
Installer version: v0.15.9
Operating system: Windows 10 Pro for Workstations 10.0.22621
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Cybertron
Snippets enabled: 0
Restricted mode: off
Plugins installed: 22
Plugins enabled: 6
1: Recent Files v1.3.5
2: Hotkeys++ v0.2.7
3: Carry-Forward v1.4.5
4: Natural Language Dates v0.6.1
5: Editing Toolbar v2.3.1
6: Plugin Update Tracker v1.4.5

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Is there a cache somewhere to recover this file. I am not syncing to anything. Just do backups to another disk. So in this case I lost one day’s worth of edits and not the whole file.

You can try the File Recovery plugin (core), which is enabled by default.

Go to Settings → File Recovery → Snapshots → View

In there, you can search for your note, and see snapshots of previous versions.

(I’m moving this to help for now, just because this isn’t exactly a reproducible bug, and 3rd party plugins aren’t really supported.)

OK. I understand. Questions for the future…

If I had no 3rd party plugins what would have been the procedure?
Do you accept any problems when 3rd party plugins are used?
Is there a log file or debug tracing I could turn on to catch what is happening, because the cashes happen about once a week?

Did File Recovery work?

I don’t know about logs or error tracing, sorry.

The procedure is listed in the template when you file the bug. And also some helpful debugging steps are listed here: Debug help

You can try some of those steps. First, I recommend downloading Obsidian fresh and reinstalling. Your installer is very out of date at 0.15.9. You don’t have the latest (CodeMirror I think?) components. Occasionally on major upgrades, you need to reinstall manually.

But the most important thing is some clue as to why it’s happening. You only wrote about the result. Not any repro steps, or the potential cause. (Not a problem! That’s just my reasoning why I moved it to help for now. And if we can spot a reproducible problem, happy to move it back to bugs.)

file recovery did work.
Thx for letting me know about that.
I’ll look into getting as up to date as possible.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.