Newlines vs paragraphs

When working with markdown, latex and other text formats, I tend to write one sentence per line, and rely upon the rendering pipeline to sort out the paragraph flow for me. This is after many years of entertainment with diffing edits between natural-language documents.

In obsidian, the editor view is rendering what I type. I press enter after each sentence. However, when I go to the reading view, it is still rendering my newlines rather than flowing the text into paragraphs. If I render to PDF, it is displaying as I would expect.

Is there some CSS or other hack I can do so that the display in the reading view uses the paragraph/newline structure used in the PDF rather than in the editor view?

1 Like

Check your “Strict line breaks” settings.

2 Likes

I think you want to turn off “Strict Line Breaks”.

I write semantically – Semantic line breaker – and have the “Strict line breaks” setting active.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.