Nesting a numbered list item by pressing tab doesn’t work with “Tab size” 4 without “Use tabs”

Steps to reproduce

  1. Press “help” to open the help vault with all the default settings.
  2. In settings → Editor, set “Tab size” to 2 and “Use tabs” to off.
  3. Create a numbered list. Try to make it a nested numbered list by pressing Tab on some items.
  4. Turn on preview mode. Notice that the list isn’t nested.

Expected result

Tab should move an item to the next level.

Actual result

Instead, tab indents an item by 2 spaces, when 3 spaces are needed.

Additional information