Nested Tags missed in Tag Panel

Steps to reproduce

  • On the first instance of Obsidian on the first computer add files with Nested Tags to a Vault

  • Open the Vaut on the another Instance of Obsidian

  • Open TAG panel

    • ** not all tags are visible **
  • One a file with a tag which is not visible and edit a file
    ( any edit /add space/ add and remove a char… )

  • It will apear on the Tag panel

  • It seems that Search do not find a tags:
    tag:#F2F/BartekFidecki before an edit a file in was not found.
    After an edit the file it was found and apears in TAG panel

  • but when I searched BartekFidecki it was found

  • when I edited a file outsite of an obsidian it also helped

  • touch doesn’t help

  • I need to edit only the one file with missed Nested tag to cause Obsidian recognize it in the rest files…

Expected result

I see all nested tags from a vault in the panel

Actual result

On the obsidian where I add a Nested Tags everything works fine - I see all my tags in the TAG panel and I can easly find them in search.

When open a vault on the another computer, only some of the nested tags is visible on the another computer.
on the computer where I add them every thing work fine.

Tags after open a panel:
image

Part of search panel:
image

Part of content with a missed tag:
image

Environment

  • Operating system: Windows 10 / Both computers
  • Obsidian version: 0.10.3 / Both Computers

Additional information

I store a vault in GitHub and sync in on my computers.

1 Like

Does this work with regular (non) nested tags?
Has this ever worked?

What do you syncronize exactly with github? The vault? The vault and .obsidian, the vault .obsidian and the cache stored by obsidian somewhere else?

Normal tags works fine.

I am sync everything without config and workspance (from .obsidian folder)

How to localise cache stored files?

I don’t understand what you sync.

A

The vault and .obsidian folder without config and workspace files (they are added to .gitignore file)

ok, does it happen if you use a text tag without the emoticons.

All Nested tags - also without emoticons have the same issue e.g. Treść/do-przeczytania didn’t work also

does changing the order/frequency help?

we’ll release an update that fixes a problem with nested tags. I am not sure it will fix your problem

no :frowning:

Is this stille happening with 0.10.5?

I’m on 10.5 and seeing the same issue. Nested tags on first computer worked fine, when opening Obsidian on a second computer I’m seeing issues.

how is you sync setup?

also do you sync before starting obsidian or while obsidian is running? can you post a screen recording?

I’ll chime in with the information I can:

  • Primary computer - Macbook running Mojave.

  • Secondary computer - Windows laptop running Windows 10

  • Syncing entire folder/vault via Dropbox

  • Secondary computer only sees nested tags, either as their own tag or as a child under their parent, after a file has an edited/added tag. AND, even then, only the file that had the tag edit/addition appears within the nested tag search.

when you close and open obsidian, do the missing tags appear?

Can you post a screenshot or screen recording? thanks!