Negative numbers while indexing vault

Hi, I am having an issue with one of my vaults. its indexing but showing negative numbers, taking a long time, then stops before finishing (or so it seems, just sits on -8 for like 20 mins).

I am accessing it on a Windows 10 PC but the vault is stored on a hard drive connected via USB to my Mac Mini. The drive is formatted as fat so both OS’s can read/write to it. The network drive is added in explorer so the system has the path and login/pw always available. I have no problem accessing other vaults on that drive.

I accessed the vault once on another Windows PC and it indexed fine. It isn’t open currently on that or any other computer.

I have other vaults on that drive and can access them fine, one had 500+ records and I just added more via file explorer and when restarting Obsidian it found and imported them giving me 700+. The vault I am having issues with only has 79 ish files.


What can I do to fix it?

Things I have tried

  • Restarted Obsidian
  • Deleted the .obsidian folder
  • Exclaimed “oh come on”
  • Tried searching help file for where the index is stored in hopes deleting it would do something

What I’m trying to do

Let the vault index so I can use it.
example it won’t let me rename a note while indexing, the name field stay what I typed in it but the Obsidian tree and File Explorer don’t change.

I figured out what was causing it. I moved all the files from the folders they were in to the vaults root folder and still had a problem. I noticed that 1 file was over 100k with 5382 lines, so I removed it. After that the vault opens no problem

I don’t know if Obsidian is choking on the size, the number of lines, or if something in the file is causing it. It is just a list of all the the built in PHP functions from around 2009. I can loose the file since it’s so old I would have deleted it anyway.

To be sure it was this file I closed the vault, re-added the file then opened the vault again, this time it sat there at 0/1.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.