Narrow non-breaking space (U+202F) displays incorrectly


The NNBSP character displays with a regular width, when it should rather be similar to the thin space (U+2009). The non-breaking behavior is still there thought. This issue appeared with the version 1, the NNBSP was correctly displayed until then.

As an aside, does Obsidian natively handle the rendering of Unicode characters? I imagined it to be delegated to standard libaries but I’m not familiar with the field.

Thanks for the feedbacks

Bug reports need the bug report template filled out and the troubleshooting steps followed.

Can you show the source text of what you’re referring to? See here for how to properly format examples for the forum:

Steps to reproduce

  • Type U+202F in the editor

Did you follow the troubleshooting guide?


Expected result

  • A narrow non-breaking space

Actual result

  • A regular width non-breaking space


Obsidian version: v1.3.7
Installer version: v1.3.3
Operating system: #1 SMP Debian 5.10.191-1 (2023-08-16) 5.10.0-25-amd64
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: Willemstad
Snippets enabled: 2
Restricted mode: off
Plugins installed: 10
Plugins enabled: 10
1: Emoji Shortcodes v2.2.0
2: Periodic Notes v0.0.17
3: Folder Note Core v1.3.5
4: AidenLx’s Folder Note v0.16.5
5: Dataview v0.5.56
6: PlantUML v1.6.6
7: Obsidian42 - BRAT v0.7.0
8: Query Control v0.5.0
9: TagFolder v0.16.10
10: Advanced Slides v1.20.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

  • Was rendered correctly before V1.0.0
  • Can be reproduced in the test vault