Multiple cursors with dragging no longer working after 1.0.3

I have been using multiple cursor feature regularly, and up until today it was working fine where I place cursor on line 1, hold option (on mac) and drag down to add cursors to lines below. Since the 1.0.3 update this evening, I can still place multiple cursors by clicking each line individually, but I can no longer place cursors by dragging. Now dragging just highlights the text, and any typing after highlight just deletes the highlighted text as usual.

Steps to reproduce

On section of text with multiple lines, place cursor at beginning of first line. Hold option (on mac) and drag cursor down the to try to place multiple cursors at beginning for subsequent lines

Expected result

Multiple cursors place at same position in all lines that were dragged through.

Actual result

No extra cursors get place, text just gets highlighted when doing option+drag, and behaves like normal highlighted text. The option key does nothing when dragging down through multiple lines.


  • Operating system: macOS 12.6
  • Debug info:
    Obsidian version: v1.0.3
    Installer version: v1.0.0
    Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:17:10 PDT 2022; root:xnu-8020.140.49~2/RELEASE_X86_64 21.6.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: off
    Legacy editor: off
    Base theme: dark
    Community theme: Obsidian Nord
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 4
    Plugins enabled: 4
    1: Citations v0.4.5
    2: Obsidian_to_Anki v3.4.1
    3: Calendar v1.5.10
    4: Kanban v1.4.6

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Multiple cursor function still works if I click to add a new cursor to each line individually, but this is quite tedious with many lines and defeats the purpose of having the feature.

I am not sure what you are talking about but everything seems normal to me.

Post a screen recording of this happening in the sandbox vault.

See below (sorry the gif conversion made it play slow). The first time, I am clicking each line individually while holding option. The second time, I have hold option while doing a click-hold-drag down the list. Up until today, this would have given my a cursor on each line, but now it is just highlighting and not adding new cursors.


thanks, I got it.

this was changed to alt-shift. forgot to add it to the release notes.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.