Mobile: Backspacing a linebreak, removes links in that line

I’m using a Samsung Tablet with a external keyboard, using obsidian mobile of course. My problem is the same as this one, but the problem might’ve beenmisunderstood so I’m reporting it. (this problem might also be present on an android phone but I don’t recall exactly)

I’m going to represent my cursor’s position by $0.

In the note: ($0 is not there, it’s jut the cursor)

Hello
$0Hi [this post](https://forum.obsidian.md/t/using-backspace-on-text-deletes-the-link-in-that-piece-of-text/62238)
Bye

If I press backspace I get:

Hello$0Hi this post
Bye

It removes other formatting as well. Like html tags are removed.

I tried this: 1. Without any community plugins; 2. Not in a sandbox but in a totally new test vault. 3. In that test vault without any core ploguins;

This bug is not present on computer. But if memory doesn’t fail it might also present on a normal android phone.

Steps to reproduce

  1. Use obsidian mobile, on an android device. (this doesn’t work
  2. Create the first markdown note above, and with the cursor in that position.
  3. Press backspace.

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

Hello$0Hi [this post](https://forum.obsidian.md/t/using-backspace-on-text-deletes-the-link-in-that-piece-of-text/62238)
Bye

Actual result

Hello$0Hi this post
Bye

Environment

I had to turn core plugins on but:

SYSTEM INFO:
	Operating system: android 12 (samsung SM-T860)
	Obsidian version: 1.4.16 (114)
	API version: v1.4.16
	Login status: logged in
	Catalyst license: none
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none

Additional information

  1. Any fixes are very welcome!

  2. In the other thread it was suggested this was a confusion related to LivePreview/Source mode. It’s not simply confusion. But the bug does not happen in Source mode, only in LivePreview mode.