Mispositioned Context Menu after Zooming In/Out

Steps to reproduce

Zooming in or out the whole application. Then right click or use the command palette to display the context menu.

Expected result

The context menu is expected to show at the cursor position.

Actual result

The context menu does not show under the cursor and is misaligned to some degree. The degree of misalignment with the cursor position is proportional to the zoom percentage. The same behavior is reproduced in the sandbox vault.


  • Operating system: MacOS Monterey and Ventura
  • Debug info:

Obsidian version: v1.1.15
Installer version: v1.1.9
Operating system: Darwin Kernel Version 22.3.0: Mon Jan 30 20:38:37 PST 2023; root:xnu-8792.81.3~2/RELEASE_ARM64_T6000 22.3.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Obsidian Nord v0.1.7
Snippets enabled: 0
Restricted mode: off
Plugins installed: 19
Plugins enabled: 17
1: Mind Map v1.1.0
2: Templater v1.16.0
3: Zoom v1.1.1
4: Periodic Notes v0.0.17
5: Copy Block Link v1.0.4
6: Obsidian_to_Anki v3.4.1
7: Tag Wrangler v0.5.6
8: Obsidian Memos v1.9.7
9: Dangling links v0.3.0
10: MarginNote Companion v0.8.3
11: Natural Language Dates v0.6.1
12: Projects v1.11.5
13: Readwise Official v2.0.1
14: Advanced Tables v0.18.1
15: Dataview v0.5.55
16: Advanced URI v1.33.0
17: Kanban v1.5.2

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I can’t reproduce. Post a screen recording of this happening in the sandbox vault.

Here’s the screen recording. I first right clicked when Obsidian is in actual size. Then repeated when zoomed in. Then again when zoomed out.

will be fixed 1.1.16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.