Migrating files with images who use the syntax ![](local file path) to obsidian

What I’m trying to do

I opened markdown files which were working fine with typora and marktext but on obsidian no images are shown!

so the files embeddings are used like this:

but obsidian seems to use a different syntax here.

I really would like to try obsidian a little bit but this would force me to still use other markdown viewers for older files.

Things I have tried

search through images and help and looked through the settings to change this.


So are there any options? I mean I could try some kind of replace of the tags or is there another option?

The example is missing — you probably need to wrap it in backticks to mark it as code:

`like so`

Try:

![](file:///home/felix/Documents/assets/2022-01-10-14-03-09-image.png)

Angel

I am on ubuntu btw

Oh I see the original syntax was like: ![](/home/felix/Documents/WS21-22-Repo/Grundlagen%20der%20Signalverarbeitung%20und%20des%20machinellen%20Lernens/assets/2022-02-08-17-32-41-image.png)

Sadly I can’t edit my post.

I strangely noticed that some images were converted to the following format:
<img title="" src="file:///home/felix/Documents/WS21-22-Repo/Grundlagen%20der%20Signalverarbeitung%20und%20des%20machinellen%20Lernens/assets/2022-02-09-12-55-16-image.png" alt="" data-align="inline">

it is working when I add the file tag! thanks! the /// is not necessary in my case.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.