Mermaid Diagrams Switching to Codeblock Spontaneously - Live Preview

Steps to reproduce

  1. Create note with a mermaid diagram.
  2. Above the mermaid diagram, use a display block reference (i.e. ![[#^]]) to display the mermaid diagram.
  3. Hit enter and start typing text.

Expected result

The screen to render mermaid diagrams consistently instead of switching them to codeblocks.

Actual result

Environment

  • Operating system: Windows 11 Pro Insider Preview
  • Debug info:
SYSTEM INFO:
	Obsidian version: v0.13.23
	Installer version: v0.12.19
	Operating system: Windows 10 Pro 10.0.22543
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 1
	Safe mode: on

RECOMMENDATIONS:
	Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.

Additional information

what’s the complete source of the document?

# Psychology Chapter 2
Biology of Behavior

![[220201 Neurons#Neurons]] 

## Nervous System

1. Broken into 3 different systems. <br> ![[#^1e7778]]
	1. [[Central Nervous System|Central Nervous System]] 
	2. [[220201 Autonomic Nervous System|Autonomic Nervous System]] 

## Endocrine System

Unlike the nervous system, the Endocrine System is the system which controls the body's hormones.  


# 
#college/harding/PSYC2010 #week/22/04 #booknotes 

# Footnotes

```mermaid
flowchart TD
A[Nervous System] --> B
A --> C
B[Central - brain and spinal Cord]
C[Peripheral] --> D
D[Autonomic - automatic action] --> E[Sympathetic - arousing]
D --> F[Parasympathetic - calming]
C --> G[Somatic]
G ---> H[Sensory Input]
G ---> I[Motor Output]
```

^1e7778

Strict line breaks are off. Vim mode is on.

thanks