Mermaid - Arrow heads missing

If a “Flowchart” made with “Mermaid Tools” does not show arrowheads, despite typing the syntax “A–>B”, is there anything I can do myself to fix this?

The bug report template needs to be completed for bug reports. Thanks.

On one of the two Flowchart diagrams made with the Mermaid Tools plugin, the arrows at the ends of the lines connecting the nodes do not appear.

Steps to reproduce

flowchart LR

Did you follow the troubleshooting guide? [Y/N]


Expected result

There should be arrowheads at the ends of the line between the nodes to show the direction of the line.

Actual result

There are only lines connecting the nodes.


Obsidian version: v1.3.5
Installer version: v1.3.5
Operating system: Windows 10 Pro 10.0.19045
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 28
Plugins enabled: 23
1: Calendar v1.5.10
2: ExcaliBrain v0.1.15
3: Chronology v1.1.5
4: Dataview v0.5.56
5: Excalidraw v1.9.7
6: Google Calendar v1.9.19
7: Habit Calendar v1.2.0
8: Habit Tracker v0.3.4
9: Heatmap Calendar v0.6.0
10: Emoji Toolbar v0.4.1
11: Graph Analysis v0.15.4
12: Luhman v1.2.0
13: Editor Syntax Highlight v0.1.3
14: Outliner v4.7.1
15: Templater v1.16.0
16: Checklist v2.2.12
17: Natural Language Dates v0.6.1
18: cMenu v1.1.2
19: Local images v0.14.2
20: Mermaid Tools v0.2.2
21: Kanban v1.5.3
22: Creases v0.7.0
23: Better Word Count v0.10.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I have two charts made in two different files. On one the arrows are there and on the other they are not.

After adding the document to Canvas, the arrowheads appeared. But they are still not there in the original document.

Please use the search function, this has been discussed before.