Mdnotes plugin for Zotero not creating note anymore

Hi, this is a new issue I’m experiencing with the mdnotes plugin for Zotero to import references into Obsidian, that I’m hoping someone can help me resolve!

I’ve been using the plugin for a couple months now and it has been working GREAT. Today when I tried to import a new reference (from Zotero reference > right click > Mdnotes > Create full export note) nothing happened. Usually it will bring up a save dialog window with my Obsidian directory preselected, and I confirm and it saves. Now, just nothing happens.

Anyone experience this and can help me resolve? If so, thanks in advance!

Things I have tried

  • export via other mdnotes option ‘Export to markdown’ (also not working)
  • enabled Zotero Debug output logging and checked logs - there is the following line:

(3)(+0010697): Error: Module zotero/filePicker is not found at chrome://zotero/content/filePicker.js [email protected]://mdnotes/content/mdnotes.js:1063:26

Is this causing it, and if so what changed and how to fix?

Here is my setup information (from Zotero debug log):

version => 5.0.97-beta.43+c5d89f6d0, platform => MacIntel, oscpu => Intel Mac OS X 10.16, locale => en-CA, appName => Zotero, appVersion => 5.0.97-beta.43+c5d89f6d0, extensions => ZotFile (5.0.16, extension), Mdnotes for Zotero (0.1.3, extension), Better BibTex for Zotero (5.4.29, extension), Zotero LibreOffice Integration (5.0.25.SA.5.0.97-beta.43+c5d89f6d0, extension, disabled), Zotero Word for Mac Integration (5.0.38.SA.5.0.97-beta.43+c5d89f6d0, extension, disabled)

What I’m trying to do

Export references in Zotero with mdnotes ‘Create full export note’ option. This was working great a few days ago.

Answering my own question here in case others encounter the same issue - this is a breaking change with the latest Zotero beta release, see this GitHub issue for explanation.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.