MathJax transform in `\style` is broken

Steps to reproduce

Insert $\style{transform: scaleX(-1);}{k}$

Did you follow the troubleshooting guide? [Y/N]


Expected result

Mirrored $k$

Actual result

transform property is ignored. Interestingly, other CSS properties passed to \style are kept.


Obsidian version: v1.4.11
Installer version: v1.3.5
Operating system: Windows 10 Home 10.0.22621
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

This worked in previous versions of Obsidian, so I’m not sure if this is a MathJax change or a change made by Obsidian. Unfortunately I don’t know which exact version is the latest one that worked, though if there’s a way to easily install different obsidian versions, I’d be happy to bisect.

1 Like

some changes were made to mathjax config a couple of versions ago because it could be used as an attack vector (e.g. run javascript).

Ah ok, good to know. Is there currently a supported way to change the MathJax config via a plugin? I read some old threads (e.g., here, and here), but I couldn’t find anything more recent. It would be nice to be able to modify the safe extension options to add transform as a supported style. Is there any more recent movement on this feature, or still something on the TODO?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.