Markdown Link after footnote is not handled properly

Steps to reproduce

  1. Untick “Use Wikilinks” in “Files and Links” section of settings
  2. Add a footnote to text - [^1]
  3. Add the footnote text - [^1]: [[Link]]
  4. Delete the last two square brackets “[[Link” and the same file should be suggested in the search.
  5. Press enter and the link will be placed, but it will not be dynamic.

Did you follow the troubleshooting guide? [Y/N]


Expected result

[^1]: [link]( is a clickable link that changes

Actual result

[^1]: [link]( was just plain text


Obsidian version: v1.3.7
Installer version: v1.3.5
Operating system: Windows 10 Education 10.0.22621
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: Everforest v0.0.0
Snippets enabled: 0
Restricted mode: off
Plugins installed: 22
Plugins enabled: 18
1: Obsidian Link Converter v0.1.4
2: Readwise Official v2.0.1
3: Excalidraw v1.9.12
4: Text Extractor v0.4.6
5: Periodic Notes v0.0.17
6: Calendar v1.5.10
7: Note Refactor v1.7.1
8: Paste image rename v1.6.1
9: Dataview v0.5.56
10: Smart Random Note v0.2.1
11: Annotator v0.2.10
12: Frontmatter Tag Suggest v0.4.1
13: Tag Wrangler v0.5.11
14: Omnisearch v1.15.2
15: Footnote Shortcut v0.1.2
16: Citations v0.4.5
17: Reading Time v1.1.1
18: Janitor v1.0.7

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information


Is it clickable in Reading View? hI assume you’re in Live Preview).

I get a clickable link on iPadOS in both Live Preview and Reading View.

Your debug info shows plugins enabled. I realize you may have generated the debug info before or after troubleshooting, but just to double-check: did you turn on restricted mode and restart Obsidian?

1 Like

FWIW, I also get clickable links in live preview and reading mode with this dummy text:

Link in a footnote: ^[[[link]]]

Another simple footnote[^1]. 

And with a different link format[^q]

  [^1]: here is a link to the file [[link]]

  [^q]: link to [the same file](link)

Tried the sandbox vault? Same outcome?

1 Like

I think this is a similar issue to what I described in the following bug report:

Similarly to HTML elements, links don’t display as expected in Live Preview if they are the first thing in the footnote content. That may be why it was not reproduced. I was able to reproduce this on v1.3.7:

[^1]: . [link](
[^2]: [link](