Markdown files saving as unreadable ".md?" rather than .md

I export reading notes from Zotero to Obsidian using a Zotero plugin (Better Notes), and recently the export files have started exporting with a “?” at the end of the file name (so, “.md?”) so that they are unreadable by Obsidian. I’m not sure if this is an Obsidian-side problem or a Zotero-side problem, but many efforts to resolve it Zotero-side have failed. Has anyone else had this problem with Obsidian and know how to fix it? Alternatively, is there any way to automatically change file names to “.md” or to get Obsidian to read files ending in “?”?

I would first make sure you don’t have a “?” in the Zotero plug in options for “Output Path”.

In my Obsidian, I currently have mine set to Sources/Publications/{{date | format("YYYY")}}/{{citekey}}/{{citekey}}.md, but it does allow me to add a “?” to the end which would result in the behavior you describe.

Oh thanks, that was a great idea. I don’t actually use the Zotero Integration plugin, though. I had downloaded it awhile ago but it was disabled. And I’ve tried exporting through it and it doesn’t have the same problem as Better Notes. (Just in the unlikely event that it could make a difference even while disabled, I checked my prior Integration settings and the output path was just {{citekey}}.md.)

I see… sorry I didn’t notice you mentioned Better Notes. I don’t have any experience with this.

As an extreme hack, I once asked the creator of “omnisearch” to look into providing text search for non-.md files. I think he added a way for his plugin to also index a list of file types you provide with the benefit of them also showing up in the navigation. So, in theory you may be able to register “.md?” in the “omnisearch” preferences so your .md? files show up.

Again, not an ideal solution, but might get you going until a real solution comes along.

Oh that’s super creative! Thanks for thinking about it with me.

I did end up figuring out the problem, though. I’ll post here for anyone who uses Better Notes and happens upon a similar one. The “?” at the end of the file name seems to be created when the filename template has a broken element. My problem took so long to fix because I had two broken elements and I was only changing one at a time. These elements also became broken only over time…I was able to use them for weeks without issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.