Markdown Embeds to specific section don't show title

Steps to reproduce

Create a file with at least one section under a heading.

Embed that section into another markdown file using ![[MyFile#Heading]].

My debug info indicates a few plugins, but the same behavior happens with 0 plugins, 0 CSS snippets, and the default theme. See screenshot below.

Expected result

The markdown filename should be shown on the top of the block (Pizza), but it’s missing, leaving an awkward blank spot that pads the section content.

Actual result

See screenshot.

Environment

  • Operating system: Windows
  • Debug info:

SYSTEM INFO:
Obsidian version: v1.1.4
Installer version: v0.15.8
Operating system: Windows 10 Home 10.0.19044
Login status: logged in
Catalyst license: supporter
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 0

RECOMMENDATIONS:
none


Additional information

The top is linking to the ![[Pizza]] and behaves normally, the second is linking to ![[Pizza#Toppings Ranking]]

1 Like

Is this the default theme?

Anyway, I don’t recall we showing the filename in headings embeds.

Original shot was the default theme, but I tested on that too, with all plugins and CSS snippets disabled.

Here’s the result. You can see in the top one which links to ![[Pizza]] the note name is in the line with the copy link icon. In the bottom there’s no note name.

Second shot in view mode:

Totally agree with @fuzzbyte . I became aware of this limitation when embedding sections and blocks onto canvas surfaces. It would be nice to show the parent note name via a hover or a container label.

FWIW - Canvas: Show title of source note for each link to section, header, and block embedded onto a card

Could this be an issue because of the link type we choose in our vault settings: Wikilinks or Mardown links?

Sorry, original shot was not the default theme. Bad typo there.