MACOS - Obsidian config files

Looking for some help for an entirely self-inflicted problem.

I was opening a vault ‘in a hurry’ and accidentally set Obsidian to open a vault based on the root of my company cloud storage I have mapped.

With all the folders I have access to there are 100Ks of files accessible via this drive and Obsidian appears to be working through them all to build the vault view.

I have tried to delete the app and reinstall and tried editing the .plist file to no effect.

Has anyone any ideas how I can ‘reset’ my Obsidian config such that it thinks it is newly installed?

Did you delete the .obsidian file?

And I don’t mean to dismiss your very real pain, but this is hilarious.

Obsidian is probably opening this vault when you launch the app. To prevent opening this vault in the future, open/create a new vault. Click the vault icon in the app’s ribbon to get to these options. Then, click the “X” next to the vault you’ve erroneously created. Finally, To remove the “vault” from the folder you’ve installed it in, just delete the .obsidian directory, as @austin mentioned. (It might not be necessary—clicking the “x” in the vault viewer might delete the .obsidian folder.)