Local files not opening

Hi all,

does linking to local files (outside the vault) work for everyone out there? Have been playing around a lot, also searching the obsidian forum - but still haven’t found any solution!

I am working on linux, trying to insert a link to a pdf like this:

[Name of the file](file:///home/user/documents/file_name.pdf)

In preview mode, this is correctly shown as a link. But if I click on it, nothing happens… If I try the same in any other markdown editor, the file instantly opens in the default app.

Did I miss anything? The file name neither includes spaces nor special characters…

Thanks for any advice!

Can you check the console and see if there are any errors?

To check for errors, first open the developer tools by pressing Ctrl-Shift-I on Windows/Linux or Cmd-Opt-I on macOS, and then go to the “Console” tab. If you want to save the error to a log file, you can right click on the error and choose “Save as…”.

No messages shown in the console.

When I open a pdf in preview mode within obsidian, “open with default app” works without any problems, by the way.

I notice that there’s a wrong hotkey guide about opening the developer tools in the help doc, it may let some people who is not familiar with Electron feel confused. I’ll fix it up, and make a pull request on the docs GitHub repository. :smile:

If you are building or modifying your own css, you can open the developer tools by using Ctrl/Cmd+Shift+I to get information on the elements you want to customize.

Are there any other ideas what the problem might be?

Are there other users facing the same problem?

Anyone working on Ubuntu Mate 20.04? Does it work for you or not?

What about users on other Linux systems?

Still struggling with this… If I don’t get it to work, some of obsidian’s great functions become quite useless for me… :worried:

Just to add:

I tried to open the AppImage via terminal, in order to check if there is any error message shown… But no, it correctly states: “open file xyz” - but still it is not opened… :thinking:

Sorry you haven’t figured this out. You might want to ask on Discord. I know there are plenty of linux users there.

+1 I can also reproduce this!

Edit: Looking a little closer at the mimeapps.list because of URL Scheme doesn't work on Linux, it turns out that opening Obsidian makes it the default application for html files, instead of the browser. I don’t know if this is related, but this is definitely a bug. I don’t think Obsidian is intended to open other local html files, but even if it is it should be added to the [Added Associations] section instead of making it the default.

Same problem here and I’m a Mac user.

Seems like this is caused by us stripping the extra / off the file:/// protocol (the third one should only be stripped on Windows). Will fix in the next insider release.

3 Likes

stipping the third did not work for me on windows but the /// and back / all the way down did