Linux: High CPU load on screen unlock, .xsession-errors fills disk

Since updating to Obsidian v1.0…

After waking up from locked screen (xfce4 + light-locker), with Obsidian running, three or four cores are pegged at 100% for about 25 seconds. During this time Obsidian window is unresponsive. At the end of ~25 seconds Obsidian becomes usable and CPUs return to normal.

During the ~25 seconds, the following error:

ERROR:angle_platform_impl.cc(44)] renderergl_utils.cpp:188 (ClearErrors): Preexisting GL error 0x00000507 as of …/…/third_party/angle/src/libANGLE/renderer/gl/TextureGL.cpp, setStorage:1036.

…is being logged to ~/.xsession-errors at the rate of 25,000-30,000 times per second.

I tried this with the Obsidian Sandbox and the same thing happened.

Steps to reproduce

  • Open Obsidian Sandbox
  • Lock screen
  • Wait until login/unlock screen reappears
  • Unlock screen
  • watch CPU graphs and line count in ~/.xsession-errors :slight_smile:

Expected result

Should be able to use Obsidian right after unlocking screen. CPUs should not catch fire. Disk should not fill with errors.

Actual result

See preamble

Environment

  • Obsidian 1.0.3 (AppImage)

  • Linux Mint 20.2

  • kernel 5.4.0-89-generic

  • xserver-xorg-core 2:1.20.11-1ubuntu1~20.04.

  • nvidia-driver 460.91.03-0ubuntu0.20.04.1

  • xfce4 + light-locker

  • Debug info: (in Sandbox)
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v0.15.8
    Operating system: #100-Ubuntu SMP Fri Sep 24 14:50:10 UTC 2021 5.4.0-89-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on
    RECOMMENDATIONS:
    none

This doesn’t happen to me on linux. It may be something specific to your system or desktop environment, or maybe a problem with a newer electron version. These things are beyond our control.
You can try to disable hardware acceleration in obsidian (settings>about)

Thank you. That seems to have fixed it.

I guess I will find out whether the note on the setting “If you turn this off, app performance will be severely degraded” is much of a problem." :slight_smile:

Thanks again.