Links to a file with a Cyrillic name do not work

Steps to reproduce

Write a link to a folder with a Cyrillic name in the note. That’s it ![Folder](C:\Users\sisin\Documents\Ярлык)
Creating a folder along this path.
In edit mode, ctrl + mouse click

Expected result

The appropriate folder will open in file Explorer

Actual result

Nothing happens. Although if the name is only Latin, the folder opens


  • Operating system: Windows 10
  • Obsidian version: 0.6.7
  • Using custom CSS: No

Additional information

The same problem with files.

Let me know if this happens with 0.7.

I haven’t seen ![folder] work at all, at least on the Mac.

0.6.7 handles a cyrillic file name with a .md extension fine.

I am also a bit confused by this bug report.
why do you use the embedding notation?

I don’t know why I wrote this, but I’m learning all the details. Can be removed "!"the behavior will not change.
References with Cyrillic letters do not open.
Any links in preview mode do not open

We are talking about other types of files - doc, xls, etc.

In 0.7 we have support for extarnal files using '‘file:///’

let me know if it works

1 Like

Not work.
And [Folder](file:\\\C:\Users) in preview mode not work:(
Obsidian 0.7.3

1 Like

it’s file:///

  1. I tried doc, docx,xlsx. These kinds of files still won’t open.
  2. A file with a Chinese name do not work, either.
  3. Besides, If there are spaces in the path, file links cannot be formed.


  • Operating system: Windows 10

  • Obsidian version: 0.7.3

  • Using custom CSS: No

whitespaces should be substituted with %20 .

1 Like

If use format like this:


the link in previw can be clicked, although file cannot be opened with default app automatically.

Thank you, it works now.

you should use the forward slash /

I know that. However, it cannot even open the link under 1 and 2.

I think the links only work if they have ascii chars in them.

Works partially
For windows, you need to change all “/” to “”. Which is not obvious and very inconvenient.
The Cyrillic alphabet still doesn’t work

Merged with another report.