Linked Mentions Being Read as Unlinked Mentions

Hi there! I’m new to Obsidian and love it so far, but I’ve searched far and wide and believe this must be a bug. When I link another note using [[note]], some of them are considered linked, and some of them are considered unlinked mentions. When I then try to link something that is an unlinked mention, it simply adds the brackets around again so it appears [[[[note]]]], but still does not link. When I take away the brackets and try to link an unlinked mention, it will create the brackets but still consider it unlinked. This is more of an annoyance, because the links do work when I click on them and bring me where I need to individual notes, but they do not appear to be connected on my graph view and makes it difficult to organize what is actually unlinked or linked.

Steps to reproduce

Open note.
Link to another note using bracket link markdown. (ex. [[note]]
Go to second note, see under linked mentions that it is considered an unlinked mention.
Try to link - fails.

Expected result

Notes are considered linked mentions and are connected in graph view

Actual result

Notes are not considered linked mentions and are connected in graph view


  • Operating system: Windows 10
  • Debug info:
    Obsidian version: v0.13.33
    Installer version: v0.13.31
    Operating system: Windows 10 Home 10.0.19043
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: off
    Plugins installed: 4
    Plugins enabled: 4
    1: Fantasy Calendar
    2: Dataview
    3: Editor Syntax Highlight
    4: Kanban

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

This also happens when there are no community plugins installed. All plugins are updated as well.

Additional information

I’ve tried to reinstall Obsidian, create new files, everything I can think of. Also my apologies if this should be in the “help” section, but I do think it’s a bug.

post a screen recording of this happening in the help vault

Hi! Thanks for the quick response. This is frustrating, because I cannot seem to get the issue to recreate in the Help Vault. It happens at random - would you mind a screen recording of my Vault were it’s happening currently? It’s not personal information on there, ha, it’s just my D&D homebrew.

ok, let’s see.
My guess before watching your vault is that you are putting links in codeblocks and we do not pickup links in codeblocks.

Here it is! I’m not using a code block and I also tried to add an example of how it sometimes does work. Please let me know if I can give you anymore information. Thanks again for the help!

I uploaded it to my drive so you can view it here:

can you attach a copy of the two files?

Side note: why are you using <h1> and not # title ?

Does it happen if you have third party plugins disabled?

Here you go! :slight_smile: I’m actually swapping it all over to # title, it was habit when I first started to use HTML

Meadyan (63 Bytes) (190 Bytes)

Yes, I did it with all them disabled as well.

Ok the issue is indeed that you use h1 and you don’t separate the text and html with blank line.

1 Like

Oh my goodness! I didn’t even realize it was only happening on my html blocks for it. I’m so silly. Thank you SO MUCH! <3

I was thinking it was outside of the code block because I had closed my h1, but it fixed flawlessly. Thank you again!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.