Link suggestions when typing are blocking and slow

Steps to reproduce

Open a vault with a decent number of notes, like 350.

Type [[.

Expected result

Link suggestions are shown without a delay.

Even if there’s a delay, expect to not block typing (the main thread).

Actual result

Without plugins or themes: Delay for half a second with the main thread locked. Leads to a very janky typing experience when internal links are used heavily.

Delay is worse if plugins or CSS snippets are enabled.


  • I know this issue has been reported in the past a few times. But it still there, and is sufficiently annoying for me to venture upon bugging the Obsidian team with it again.
  • I do not particularly care about all the numerous items in the default suggestion list. I think nobody really does. Perhaps the “cheapest” way to fix this is to simply cap the number of the items in the suggestion list. Or populate it in an asynchronous way.


  • Operating system: WIndows 10

  • Debug info:

Obsidian version: v1.1.9
Installer version: v0.15.6
Operating system: Windows 10 Enterprise 10.0.19045
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 2
Restricted mode: off
Plugins installed: 11
Plugins enabled: 5
1: List Callouts v1.0.10
2: Image Toolkit v1.3.1
3: Table of Contents v0.1.3
4: Tag Wrangler v0.5.5
5: Supercharged Links v0.9.3

P.S. I can generate and provide a test vault, if that will make your life easier and the fix faster

I’m not seeing that on Mac or iOS with >6,000 notes.

Does it still happen if you turn on Settings > Community Plugins > Restricted Mode? If that fixes the problem, my first guess at a culprit would be the Supercharged Links plugin. If it’s caused by a plugin, try updating your plugins — unfortunately it doesn’t happen automatically and you have to push buttons in Settings > Community Plugins.

@CawlinTeffid This happens without any plugins, themes, and snippets active. Here is how it looks with all of that turned off.


1 Like

The issue went away after I deleted Cache and IndexedDB and restarted Obsidian. Even with plugins and snippets the suggestions are snappy again. That can work for me as a workaround.

1 Like

It happened to me a couple of time.
closing and restarting Obsidian resolved the issue.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.