Line numbers are not visible anymore

Hi all,

my line numbers are not visible anymore, do you have a clue why?

I use the minimal theme, but they are also not visible, if I use the default theme…

I have them activated under Editor => show line numbers

here is my debug-info:
Obsidian version: v1.4.3
Installer version: v1.3.5
Operating system: Windows 10 Pro 10.0.22621
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Minimal v7.1.1
Snippets enabled: 0
Restricted mode: off
Plugins installed: 62
Plugins enabled: 28
1: Hider v1.3.1
2: Advanced Tables v0.19.1
3: Natural Language Dates v0.6.1
4: Calendar v1.5.10
5: Excalidraw v1.9.17
6: Underline v1.2.1
7: Outliner v4.8.0
8: Tasks v4.6.0
9: Copy as HTML v1.1.3
10: Templater v1.16.0
11: Hotkeys++ v0.2.7
12: Hotkeys for templates v1.4.3
13: Periodic Notes v0.0.17
14: MetaEdit v1.8.2
15: Dataview v0.5.56
16: Obsidian42 - Strange New Worlds (SNW) v1.2.2
17: Minimal Theme Settings v7.2.1
18: Style Settings v1.0.6
19: Regex Find/Replace v1.2.0
20: File Tree Alternative Plugin v2.3.5
21: Metadata Menu v0.5.1
22: PDF Highlights v0.0.4
23: Numerals v1.2.0
24: Quick Latex for Obsidian v2.6.2
25: Extended MathJax v0.4.1
26: Tag Wrangler v0.5.11
27: Spaced Repetition v1.10.1
28: Obsidian Charts v3.7.2

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Have you tried the troubleshooting steps to pin down the issue?

yes I did all the steps, but because the line numbers are appearing in my sandbox vault, I didn’t post it as bug report.

The following steps I have done:

  • obsidian is up to date
  • check sandbox-vault => yes, line numbers appear here
  • disable all community plugins => no, line numbers still don’t appear
  • update themes and use default theme => no, line numbers still don’t appear

Got it!

After turning on Restricted mode, a restart is a good idea. Also, are you using any custom CSS snippets?

It’s a bit of a chore, but you could try (with your vault closed), moving one .json settings file out of your .obsidian folder and opening the vault. If there’s no change, you can replace the original file and move on to the next one.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.