Limit on block embedding

Steps to reproduce

  • Make a new file.
  • Paste contents from here (it’s just numbers from 1-200)
  • Try to embed any block after number 100

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

It should allow me to embed any block.

Actual result

The dialogue box shows only first 100 blocks.

Environment

SYSTEM INFO:
	Obsidian version: v1.5.8
	Installer version: v1.4.16
	Operating system: Windows 10 Pro 10.0.22631
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none

Additional information

Screenshot for reference.

This was asked several time.
It’s not a bug. The list that appears is meant as a suggestions not as an exhaustive list.
The more you type the more it refines.