Issue when using `

I don’t know if this is a bug, or if I’m missing something.
Sometimes when I try to use `` to add some text, when I press ` it only shows me one of them instead of ``

In this particular example below, you can see that my note already has a RegEx at the top inside ``, then normal text, and when I hit ` I only see one, then I add the second one, and when I paste the RegEx on my clipboard, it converts the ` to ````

Is this a bug? Or what am I missing?

Obsidian issue

I noticed that if I copy, for example, the word “characters”, when I paste it it doesn’t convert it to ````, but the issue of hitting ` and only seeing one instead of two is still there

EDIT: Ok I tested another thing and I believe this is a bug, but maybe someone can clarify this for me. I noticed that if the beginning of my note is something using ` then after that, every time I use \ it always shows me 1. So this “bug” goes away if I start my note with simple text OR even if it’s just an empty line

Obsidian issue2

So my question is: is this a bug, or is it normal? If it’s normal, why is that?

The backtick character on most keyboards is an accent character and is often used to type characters like èàòù, so therefore it often doesn’t show anything until the second character is entered. The flipside of this is that to get the character itself you might need to hit the combination of the backtick followed by the space character to get the single backtick.

So this is not a bug, but more of a feature related to accented characters.

1 Like

I’m not sure we are talking about the same thing…?
When you hit ` it always adds two of them so you can type something inside (Preformatted text, I guess that’s what’s called), similar to when you hit " or ( or [
It automatically adds the opening and closing symbol.
Check the example below where you can see what I mean.
Starting the note with, for example, `123` then adding normal text, the next time I hit ` it will only add ` instead of ``

If I start with normal text OR an empty line, then whenever I hit ` it always adds ``

So unless this is by design (which I would like to understand why), it seems like a bug to me. Why would it change the behavior if my note starts with preformatted text opposed to regular text or an empty line?

Obsidian bug

I’m able to reproduce at least part of this.

In an empty file in the Sandbox vault:

  1. Type a backtick and then some text.
  2. Move to the end of the line and add 2 newlines.
  3. Type a backtick.

Instead of a backtick on either side of the cursor, only 1 appears.

In an empty file in the Sandbox vault:

  1. Type some text with no backticks.
  2. Move to the end of the line and add 2 newlines.
  3. Type a backtick.

As expected, autocomplete produces a backtick on either side of the cursor.

1 Like

What do you mean? The only version you didn’t share was the one where you add an empty line as the first line and then start with the first example (backtick instead of normal text). Can you try this as well and see what you experience? In my case, when I have an empty line, everything works as expected, similar to your 2nd example. So the issue seems to be there only when the first line of the note starts with the backtick.

For example if I add a single letter and then add the backtick, that one and all of them after that work as expected. So the issue is the first line and first character being the backtick.

Can you test it?
Thanks

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.