Isnt this a valid Yaml? up: [2022-11]

I use Breadcrumbs which works fine for other texts but the next phrase doesnt work:

up: [2022-11]

I tested 2022- which worked and also 1-2 worked but 2022-11 did not. Any idea?

Aren’t you supposed to use double brackets? As in [[2022-11]]?

I’ve not used that plugin, but the documentation seems to always use double brackets.

Regards,
Holroy

I tied also that but it didnt work.
Everything else works with one set of brackets.
Its also weird that

up: [2022-1]

works but

up: [2022-11]

doesnt.

A single bracket means an array (list of values).
Double brackets means a link (but in yaml need to be inside quotes): "[[file]]"
So, in your case what’s “2022-11”?
If it’s a simple string, then in format “2022-11” dataview (what Breadcrumbs use, I think) read it as an ISO date; but “2022-1” not (to be a date “yyyy-MM” need to be “2022-01”).

1 Like

That solved it. I put it as:

up:   "[[2022-11]]"

There is some weird inconsistencies, depending on if its numbers or words you need to apply different tricks.
This works:

up: 2022

But this does not:

up: Friends

plus the examples ive mentioned above. All the other notes works just finel with the next format:

up: [2022-11]

So i guess for dates there is a need to use this workaround and put double brackets and quotes.

No need to guess! YAML is documented. The official documentation is hard to read, but Wikipedia has a decent description of the syntax.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.