iPadOS - Actual cursor and cursor graphic disconnect when switching back from another app

Steps to reproduce

  1. Open Obsidian 1.0 on an iPad & start a note
  2. Switch to a different app (Zotero, in my case) and select text with your finger.
  3. Switch back to Obsidian.

Expected result

The cursor to be where I left it.

Actual result

Since updating to Obsidian 1.0, depending on where I selected text in the other app, the blinking cursor indicator is either several lines below where I left it with an invisible cursor a word ahead of where I left it OR the cursor indicator is where I expect, but the actual editing is happening several lines up.


  • Operating system: iPad OS 15.7
  • Debug info:

Operating system: ios 15.7 (Apple iPad)
Obsidian version: 1.4.0 (80)
API version: v1.0.0
Login status: not logged in
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 10
Plugins enabled: 0


Additional information

Please help. I use Obsidian for everything. (And thank you for making it!)

1 Like

Didn’t test extensively but can confirm unexpected cursor placement after selecting text in another app (Safari) on iPadOS 15.7.

If text is highlighted in Obsidian, the selection stays put after selection text in another app.

I’m hitting the same thing - my pattern of usage is “cmd-tab” to see another window, then “cmnd-tab” back to Obsidian. The visual cursor appears to shift on re-appearance of Obsidian, but if you type - it goes to the place where you originally left the cursor, but with the blinking cursor offset in some odd direction (usually, but not always, lower in the screen).

I’ve found that quickly scrolling up or down and tapping elsewhere, then scrolling back and tapping will reset the cursor, but it’s kind of an annoying workaround.

This is with iOS 16.3.1, and Obsidian 1.4.3 (95)

I’m not seeing weird behavior anymore (same versions as you). My “other” apps this time were Books and Safari (I don’t recall what I used last time). I dug out my keyboard in case that mattered and tried with Cmd-Tab, and still no weirdness.

Could you try the steps in Debug help ?

1 Like

Absolutely - I’ll report back after I’ve done that. And it was jumping into reading a PDF in Books and back that was the second app in my case as well.

Yep, definitely still happening. iPadOS, Landscape mode with keyboard. Larger document page that I’m scrolled down into, adding into bulleted lists, if that makes a difference.

  • type something in the list
  • manually tap the cursor down a couple spots to where I want to add next
  • cmnd-tab to Books, read PDF a sec, cmnd-tab back
  • start typing

Cursor is offset significantly below where values are going in. It doesn’t happen every time, but I’m able to reproduce it pretty quickly.

Here’s a screenshot from when it was happening:

I just typed “dsg” and you can see it in the bulleted list, and the cursor floating down below there.

(No extensions, no themes, no plugins - all stock Obsidian)

1 Like

Hmm. I wasn’t able to reproduce, but I’ll try again later when I have more time.

1 Like

If I can help further, I’d be happy to do so. Please let me know how - incl a video call where I share my screen if that would assist in anything.

is this still happening in v 1.4.4?