iOS Mobile App Crashes on Title Editing (custom font)

Seems like you could reproduce the bug already, but just in case: yes, I did use iFont to install the font on iOS.
The error seems to be on the Text font, not the interface one.

Yep, used iFont to install the font on my ipad and iphone, and the normal FontBook app to install on my Mac.

I also used to have font apps on my iPhone, but can’t remember their names. And I had the font iA Writer Quattro installed at some point. Currently I don’t have any custom fonts installed on iOS.

I know the problem is with custom fonts, but if it helps mine is with italics, but only after I use bold I tested it with ==highlight== also and it worked.

1 Like

I’m experiencing the same thing - if I type ** or **** and then try to type between them (or edit text between the formatting characters), Obsidian reliably crashes. If I apply formatting to the text after it’s written, there’s no crash. This has happened both with custom fonts (Quicksand, Lexend Deca) and with iOS system fonts.

1 Like

I’m experiencing the same issue

@liam if it helps, my JetBrains Mono was installed via AnyFont app

Running into the same problem…

Same issue, also with IA Writer Quattro (installed with Fontcase). Crashing almost any time I try to edit a note title or heading. No crashes after switching back to a system font.

When I was typing in a periodic note and used * to create italics I noticed my Ipad app would crash. I thought it was connected to a theme change or something but did not know how to troubleshoot so I was sent here - instead of trying the protocol I see people mentioning font issues. I had two or three font selections for the interface and text fonts. I removed all fonts from each group and selected/added Arial as my only font. I tried to reproduce the issues and was unable to do so. I do not think this is a plug in issue - it is a font issue causing the app to crash.

I have the same issue and can reproduce it. To answer your question, I’m using the iA Writer Duo S font, which I installed on my iPhone specifically for use with Obsidian.