iOS and iclould: Stuck on loading workspace / Unresponsive after start

I am also affected.

  • No .git folder or plugin.
  • Deleting workspace.json doesn’t help.
  • Downloading the folder in iCloud does not help, however opening and forcing sync of the vault from the iOs files app occasionally gets me unstuck.
  • Definitely worse when signal/wifi is weak

Happy to help debugging if helpful.

I got same issue on my iPhone.
For my ipad there is skip button to skip sync configuration files.
it took me to my vault.

for iphone I have to wait for eternity and end up getting nothing.

I tried all the trick from above and still having issue.

Same issue and will not open on Mac desktop. Super frustrating because I use this daily for my work log and my daily standup notes.

I just removed and redownloaded it to the same effect.
Version downloaded was from the Obsidian Download link which is currently 1.5.12 - also, the timing on this is really awful because I have been talking Obsidian up and am even doing a Lunch and Learn on how great it is, but now I can’t even load my workspace after trying all the above.

edit: The same effect as above, where it works for a day or so and then stops working.

1.6.x was released to insiders on mobile.
Has the situation improved/solved when you use it? Are you still stuck on loading workspace?

@somnicide if you have problems on macos desktop, it is certainty a different problem that the one in this thread.
Most likely a plugin problem. (Try this procedure C)

I just bought Catalyst and tried the insider version for iOS and the latest one released on the AppStore. I believe both are version 1.6.2.

On my side, the problem got even worse. Now it is completely unusable on iOS. Deleting workspace-mobile.json doesn’t help anymore. It is Loading workspace... forever. Sometimes it seems to freeze for a few seconds and then the animation continues on.

I managed to open a note two times, only to have the app freeze instantly. Once I was able to scroll down about 10 lines before it froze.

How can I install an older version?

Created an account just to join this thread; I’ve always had the same problem loading Obsidian - it frequently (but not always) hangs on “Loading workspace”. In the past force quitting it and relaunching seemed to work. Now since 1.6 I can’t get it to launch on my iPad at all, while it loads fine on my iPhone and my Mac. Like others, I’m using iCloud. Only a couple of non-core plugins (but based on the thread, this doesn’t seem to be plugin related).

We made some improvements to iOS/iCloud support in 1.6 but didn’t think this problem would be fixed. And, unfortunately, it wasn’t. This problem is not related to workspace-mobile.json.

Our debug efforts currently point to a problem with the iCloud API used to check if the config files are present on device [1] .

It seems that this function takes progressively longer to complete the more files you have (including non-config files and files in other vaults!), and it doesn’t make a difference if the files are already on device.

My suggestion for the people affected by this problem is to try to limit the total number of files stored in Obsidian’s iCloud folder (across all vaults) and see if it helps. We will keep investigating this issue!


  1. iCloud can and frequently does evict files from iOS devices to save space, there is currently no way to stop this from happening ↩︎

The link below refers to macOS 15 Sequoia, but if the new setting is made available on iOS 18 as well perhaps it will improve performance when syncing through iCloud, if it helps to speed up the checking process. Big IF.

How can I help you?

@anon23099027 there is no way that we are aware of to disable automatic eviction of files on iOS yet (there is on macos).

@DAn7 if we need testers/debuggers for this issue, I will post a message in this thread. Thanks!

1 Like

We are getting some reports that iOS 18 Beta is adding the possibility to keep the files local on mobile.

We do not know if this option will be in the final version of iOS 18, nor if it is only manually selectable by the user and not programmatically accessible by the software (us).

We also do not know if it will positively impact this issue (related to checking) or more broadly the “waiting for iCloud to synchronize” (related to checking and downloading). But we can hope.

2 Likes

Potentially great news. Thanks.

Ryan posted something similar on a different thread:

1 Like

I am not sure what changed lately. The problem seems to have vanished on my side.

Here is my fresh debug info. I have been using it for days, and no more freezes.

SYSTEM INFO:
	Operating system: ios 17.5.1 (Apple iPhone11,6)
	Obsidian version: 1.6.3 (143)
	API version: v1.6.3
	Login status: not logged in
	Live preview: on
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none