Internal link with custom display text not getting Markdown rendered

Steps to reproduce

  • Create an internal link where custom text uses Markdown, e.g. [[Data type|`record` syntax]]

Did you follow the troubleshooting guide? Y

Expected result

The Markdown to be rendered, e.g., code snippets to be properly formatted.

Actual result

The Markdown is left as-is.


Obsidian version: v1.3.7
Installer version: v1.3.5
Operating system: Darwin Kernel Version 21.6.0: Thu Jul 6 22:18:26 PDT 2023; root:xnu-8020.240.18.702.13~1/RELEASE_X86_64 21.6.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Paste URL into selection v1.7.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Could be different, but I’m pretty sure Markdown formatting is disabled within [[wikilinks]].

I ran into this issue myself (also using v1.3.7). The Markdown formatting should be appled to the display text of an internal link. Currently the formatting is inconsistent with a normal Markdown link.

## Internal Links (Formatted wrong)
[[Start Here|`Start` Here]]
[[Start Here|*Start* Here]]
[[Start Here|**Start** Here]]
[[Start Here|***Start*** Here]]

## Markdown Links (Formatted correctly)
[`Start` Here](
[*Start* Here](
[**Start** Here](
[***Start*** Here](

Note the issue mentioned by ariehen pertains to the file name porition of the internal link. This issue is about the display text portion.