Installed themes not showing in list / deleted themes

Steps to reproduce

  • Updated to v0.16.2
  • after some days installed themes are not showing up in themes list, despite being located in “themes” folder
  • need to reinstall theme

Expected result

Installed themes are found by Obsidian

Actual result

After some days (2-3) Obsidian fails to find the theme despite it being installed and located in the “themes” folder


macOS 12.5.1

Obsidian version: v0.16.2
Installer version: v0.14.6
Operating system: Darwin Kernel Version 21.6.0: Wed Aug 10 14:28:35 PDT 2022; root:xnu-8020.141.5~2/RELEASE_ARM64_T8101 21.6.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: off
Legacy editor: off
Base theme: light
Community theme: Minimal
Snippets enabled: 2
Restricted mode: off
Plugins installed: 21
Plugins enabled: 20
1: Typewriter Scroll v0.2.2
2: Advanced Tables v0.17.3
3: Dataview v0.5.43
4: Footnote Shortcut v0.0.9
5: Fullscreen mode plugin v0.1.2
6: Kanban v1.3.17
7: Pandoc Plugin v0.2.5
8: Paste URL into selection v1.7.0
9: Reading Time v1.1.1
10: Minimal Theme Settings v6.0.2
11: Sliding Panes (Andy’s Mode) v3.4.0
12: LanguageTool Integration v0.3.0
13: Better footnote v1.0.1
14: Better Word Count v0.8.1
15: Outliner v3.0.0
16: MetaEdit v1.7.2
17: Bible Linker v1.3.1
18: Citations v0.4.4
19: Zotero Integration v2.2.24
20: Smart Typography v1.0.18

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

1 Like
  1. Has the theme been updated for 0.16+

  2. Perhaps the installer you are using also needs to be updated

Are you using Obsidian Mobile, what do you use to sync to mobile?

What’s the content of that folder?
Both after you install the theme and when obsidian can’t see the theme.

Yes, I’m using Obsidian Mobile with Obsidian Sync.

In the folder I see the installed themes. This doesn’t change when Obsidian can’t see the theme.

what’s inside the each theme’s folder? What’s inside minimal? what’s inside typomagical?

Inside the Minimal folder is:

  • manifest.json
  • theme.css

The Typomagical folder is actually empty.

It now happened again. (First time after first reporting this issue)
Somehow the Minimal folder is now empty:

Out of curiosity, have your iphone and/or ipad been fine (theme wise)? Has this happened after you used one of them?

a patch for this will be release in the next mobile version 1.3.2.

On mobile everything is fine.
I’ve used the mobile apps for over a year without a problem. This occurred only after upgrading to v0.16.x


Using mobile and syncing theme settings is what’s causing it. A fix is on the way (see above).

I had similar issues. Created a custom config .obsidian.ios for the time being (to keep desktop 0.16.x and mobile 0.15.9 settings apart) and no problems since.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.