Inline date field not appearing in Dataview

Repost due to formatting issues

Hi all,

I have a one note per task workflow. Tasks look like this:

tags: task
creation_date: 2023-03-30 19:56:22
project_name::  [[projects/1nbox  (Project).md|1nbox  (Project)]]
task_link:: [↪️](task-2023-03-30-19-56-22)
task_description::  This is just a demo task 
task_status:: created
task_priority:: medium
task_assigned_team:: MYSELF
task_due:: 2023-03-30

# This is just a demo task  


My due date: `= date(this.task_due)`

## Logbook

- 2023-03-30 19:56:22 Task created

Reading View:

In my daily note I’ve got a dataview query to have an overview of my todo’s:

TABLE WITHOUT ID task_description as Task, project_name as Project, task_link as L , task_priority as Priority, task_status as Status, task_due as Due
FROM "tasks"
WHERE contains(task_assigned_team, "MYSELF") AND task_status != "done"
Sort task_due Asc

The output looks like this:

No error messages are shown when entering reading mode in my daily note.

Not sure if this affects the Dataview behaviour: all tasks are within one “tasks” folder and part of a DB Folder.

What I’m trying to do

Show the inline date field in my dataview query.

Things I have tried

Serveral modifications to the query ( such as date(task_due), etc.).

I added that query to my local copy of that task (and slightly modified related to the FROM clause), and when in reading view I get this:

In other words, everything works as expected.

Could you do a Show debug info and report what you get back out of that? (Either click in left side-bar as in image or hit Cmd/Ctrl P, and enter “Show debug info” )

Have you restarted Obsidian lately? If not, please restart to see if that changes anything. It could be some error state within Dataview or something like that which could cause this, as it clearly isn’t anything directly in what you’ve shown us here.

Thank you holray. I restart my machine/obsidian daily.
Here the debug info:

Obsidian version: v1.1.16
Installer version: v1.1.9
Operating system: Windows 10 Enterprise 10.0.19044
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: Atom v0.0.0
Snippets enabled: 1
Restricted mode: off
Plugins installed: 19
Plugins enabled: 18
1: Calendar v1.5.10
2: Dataview v0.5.47
3: Templater v1.16.0
4: Buttons v0.4.19
5: QuickAdd v0.8.0
6: File Tree Alternative Plugin v2.2.8
7: Outliner v4.2.1
8: CSV Table v1.2.0
9: Open Link With v0.1.8
10: Tag Wrangler v0.5.6
11: Table of Contents v0.1.3
12: Pandoc Plugin v0.4.1
13: Advanced Tables v0.18.1
14: DB Folder v3.1.3
15: MetaEdit v1.7.2
16: Image Toolkit v1.3.1
17: Heading Level Indent v1.0.3
18: MSG Handler v0.0.6
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

It wouldn’t hurt to reinstall Obsidian to get the installer up to version 1.1.16, but that shouldn’t matter too much in this matter. However, you’re a few version behind on Dataview, where the current version is 0.5.55, so give that a go.

Go to Settings > Community plugins, and hit the Check for updates button, and update your plugins. At least, update Dataview, and then try again.

I just updated Dataview and restarted obsidian - the dataview output is still without a date.

Just reinstalled obsidian to get the newest Installer Version - still no dates being displayed…

holray, many thanks for your help!
I found the solution - i had to set the date format in Dataview:

I don’t recall ever changing this field from default, but using yyyy-MM-dd solved my problem.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.