Incorrect indentation of 2-spaced sub list items in Reading View

Steps to reproduce

  1. Open sandbox vault
  2. Settings → Editor: Uncheck Indent using tabs and set Tab Indent Size to 2.
  3. Paste this:
1. Parent 1
  1. Child 1
  2. Child 2
2. Parent 2
  1. Child 1
  2. Child 2

Expected result

The edit view looks correct.

image

Actual result

Switch to the live view and notice the incorrect numbering.

image

Environment

SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.4.13
Operating system: Windows 10 Home 10.0.22631
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 0
Plugins enabled: 0

RECOMMENDATIONS:
none


Additional information

This is not a bug. In markdown, two spaces are not enough to indent a numbered list.

In a previous project I used to write with two spaced indents for our markdowns following our linter rules.
However I noticed that this is a common issue with markdown itself as other people had the same issue on different docs/apps that render markdown when they used 2-spaced indents.

I’ll close this issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.