Incorrect header created in canvas card

Steps to reproduce

  • Create a new canvas page
  • Right click to create new card
  • enter some information into the card
  • Hit ‘Enter’ to create a new line
  • put an ‘=’ sign
  • Rest of card will be header formatting

Did you follow the troubleshooting guide? [Y/N]


Expected result

Formatting is not in header mode

Actual result

Formatting is in header mode


Obsidian version: v1.5.12
Installer version: v1.5.11
Operating system: Windows 10 Home 10.0.22631
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 4
Plugins enabled: 4
1: Annotator v0.2.10
2: Better Word Count v0.10.0
3: Highlightr v1.2.2
4: Colored Text v1.0.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information


Not 100% is this is intended behavior and I would investigate more but I am a struggling grad student. Anybody else is free to investigate more. Even if its intended I would argue that it is a bit counter-intuitive to make header information appear

That sounds like alternative Atx-style Markdown headings.

You can do it here as well. 

You can do it here as well.

Interesting! Didn’t even know this existed. I agree that appears to be the case, thanks! Marking as solved

If you really need a = there, you can escape it with a \ to prevent the Markdown formatting from kicking in. e.g.


or put some text after it:

= more text
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.