Images not showed

The images are not shown on Obsidian on my notebook, but on my main PC (not notebook) they are shown, I tried to copy and paste the obsidian folder from my main PC to my notebook, but the problem still exists. I tried to reinstall obsidian, both in appimage and snap version, I updated plugins and themes but it didn’t work. I saw that other users had this problem, so I tried renaming some images to see if the problem was with the names, I deleted all the emojis from the folder names but it didn’t fix. I updated the operating system and all the packages, I also tried to restart the computer but it doesn’t work anyway. I checked that the images were not corrupted or something similar from the OS expolorer file and they looked good.

Can you show the actual code, so we can see the link syntax you are using?

Switch to “Source mode” for your screenshot, or just copy paste the Markdown text directly into the forum, surrounded by triple backticks so it shows as code ```.

Like this:



> [!image] 
> ![[Pasted image 20221015194153.png]]

Can you run “Show debug info” command in Obsidian, on your notebook where the images are not working?

Run that command (Ctrl-P), and share the results here, if you please.

Obsidian version: v1.0.0
Installer version: v1.0.0
Operating system: #1 SMP Sat, 15 Oct 2022 06:43:47 +0000 5.15.74-1-lts
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Things
Snippets enabled: 9
Restricted mode: off
Plugins installed: 34
Plugins enabled: 25
1: PDF to Markdown v0.0.7
2: Templater v1.14.3
3: Admonition v9.0.5
4: Mind Map v1.1.0
5: Emoji Toolbar v0.3.2
6: Outliner v4.1.0
7: Kanban v1.4.6
8: Natural Language Dates v0.6.1
9: Calendar v1.5.10
10: Find orphaned files and broken links v1.8.0
11: Banners v1.3.3
12: Editor Syntax Highlight v0.1.3
13: Dictionary v2.21.1
14: Recent Files v1.3.3
15: Advanced Tables v0.17.3
16: Obsidian Git v2.7.0
17: Style Settings v0.4.12
18: Settings Search v1.2.0
19: Excalidraw v1.7.25
20: Icon Shortcodes v0.9.7
21: Icon Folder v1.3.31
22: Pandoc Plugin v0.4.1
23: File Explorer Note Count v1.2.0
24: Diagrams v1.5.0
25: v1.0.4

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

EDIT: In the vault sandbox the image works… :thinking: , i will try change theme and disable various plugin…

EDIT3: i tried to create a new vault (without plugins or themes), but the images not works, but the same images used in sandbox vault works…

EDIT 4: I realized that the font configured in the settings was not installed on my operating system so i installed the missing font, now if I insert images using CTRL + C and CTRL + V the images are displayed, but those already present in the attachment folder are not displayed

Well that is curious. I wonder if there is some odd symbol or character in your image names, or the path in the links. (But I don’t know.)

PROBLEM SOLVED: i deleted the .obsidian folder (the folder that contain plugin,themes,settings ecc…, it’s contained in Vault folder), then i deleted:

  • Obsidian appimage (I use linux)
  • Obsidian folder in ~/.config/obsidian folder (the folder that contain applications data)

and then i reinstalled obsidian and now works!

(obviously i tried to reinstall obsidian several times but i didn’t think about deleting the obsidian configuration folder ~/.config/obsidian)

Thanks anyway for trying to help me :wink:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.