Images don't display anymore

What I’m trying to do

Copy and pasted screenshots into obsidian document in editing mode. When I switch to presentation mode, the images are not displayed.

Things I have tried

All images are local, .png format. Now even images in older documents which definitely did work, now don’t display anymore. When I open the image files locally from the filesystem, they are displayed correctly in the shotwell.
OS is Ubuntu 22.04. Obsidian is up to date.

Does someone have an idea where this could come from? Someone experiencing the same issue?

ctrl-mouse-over also does not display the images.

Are the images copied into your vault when you paste them into a note?

Could you paste the debug information here? (ctrl + p → Show debug info)

Does this thread help?

1 Like

I thought about this, too - but there it is a language-related problem (using Chinese named folders). As in the current case it obviously used to work until recently, I guess the problem may be located somewhere else… :thinking:

1 Like

Believe it impacts on other languages as well (something about accented characters). Don’t know what language the OP is using.

yes, in the attachment directory


Obsidian version: v1.3.4
Installer version: v1.3.4
Operating system: #79-Ubuntu SMP Wed Apr 19 08:22:18 UTC 2023 5.15.0-72-generic
Login status: not logged in
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: Minimal v6.2.0
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 3
1: Mind Map v1.1.0
2: Calendar v1.5.10
3: Advanced Tables v0.18.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Don’t think so. No non-ascii characters neither in the file nor the filename/path.

Hmm, difficult… At a first glance, nothing wrong with your settings.

Let’s try to narrow down this issue:

  1. Does it work in the Sandbox Vault?

If it doesn’t, then

  1. Is it possible that you changed any file or folder permissions recently?
  2. Is there any console error? (ctrl + Shift + i)?
  3. Could you share an image of the note in source view (editing mode)?
  4. Or maybe a screencast of this happening?

Does it work when you change the attachment directory?

I overlooked a special character in the path, changed it, now it seems to work!
Thank you!

@alltagsverstand @anon63144152 Thank you for your help! Problem was special character in the path (see Images don't display anymore - #4 by eightning in this thread)
Sorry that I overlooked it at first, didn’t mean to waste your time.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.