Image is not displayed if they are deeper than 10 folders from the vault level

Steps to reproduce

  1. Create a note with embedded image in same folder with the same image;
  2. Move the folder to other folders with a total depth of 10 from the vault level;
  3. Restart Obsidian and open the note with image.

Expected result

Correct display of the image embedded in the note.

Actual result

The image is not displayed even if it is opened in a separate tab.


  • Operating system:

Windows 10

  • Debug info:

Obsidian version: v1.1.16
Installer version: v1.1.9
Operating system: Windows 10 Pro 10.0.19045
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 11
Plugins enabled: 7
1: Advanced Tables v0.18.1
2: Tag Wrangler v0.5.6
3: Obsidian Functionplot v1.2.1
4: Dataview v0.5.47
5: Waypoint v1.4.0
6: Surfing v0.8.16
7: Folder Note v0.7.3

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I can’t seem to reproduce this using Windows 11 (22H2) and Obsidian 1.1.16 (1.1.16). Restarted a few times and moved the “10-note” around to different folders.

Have you tried in Restricted mode?

1 Like

Yes, I tried in Restricted mode, but it seems that the problem is not in community plugins. I think I have found the answer.
Windows has a character limit of for a file path of 260 characters. If I would try to create a folder with a full name of more than 260 characters, I get a message about it, but only if I’m working on my system disk.

However, if I would work on my second hard drive I can create as many folders with any names as I like and there will be no obvious errors or warnings.
I’m using my second hard drive for my vault, that’s why I could create a full path name of more than 260 characters to a file without warnings, and that’s why there was a conflict in the app.
But in another thing, when I tried to use my system drive for a vault, I got warnings in system explorer, but not in Obsidian itself, so the problem recurred.

P.S.- It’s funny that the image is displayed correctly if it has a valid name length or immediately after transferring the image to a folder with a length greater than the limit, until the application is restarted. Obsidian can display attachments with a name longer than 260 characters only if they are cached, I guess.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.