Im getting a white window screen whenever I try to open Obsidian

What I’m trying to do

Im trying to open the app the whole day but its just white freeze screen

Things I have tried

  • restart the app over and over again after killing it with task manager
  • restart the laptop and try to open it
  • Uninstall the app and downlead the last version from the website and install it

I have windows 10 Pro x64 and this is the screen Im getting

Any hints

With Obsidian closed, you could try moving or renaming your VAULT/.obsidian/ settings folder to see if it helps. This folder has your settings/themes/plugins, but none of your notes.

If Obsidian starts, you can selectively move parts of that folder back, or just start fresh with settings.

If Obsidian doesn’t load, you can put that folder back as it’s probably not the issue.

1 Like

I tried this and I think its not the issue , still having the same white screen , I think its something about JavaScript couldn’t figure out what its exactly ? it happened after installing docker app but I uninstalled and still having the same problem with obsidian.

I think the problem is in windows but I don’t know how to figure it out

Trying a different OS user account has helped a few times (Windows & macOS) to narrow down if the issue is specific to your user account or system wide.

1 Like

I’ve created new guest account just to try this and installed new version of the app but got the same white blank screen , this is the most weird problem I’ve ever met I tried every possible solution I know but still the same I even run the app in safe mode but same problem , I still don’t understand what’s caused or why this problem is happening

its weird because I thought the problem with JavaScript and node js but I have VS code which is built as I know with electron the same framework obsidian build and its working very well , so the problem is just with obsidian

Update : I looked for a portable version of the app and installed it and it works , but still the installed official app don’t work , even that I can open the portable version in the same user account .

Since the update to installer 1.14.x I have had this problem - intermittently - on openSuse Tumbleweed running Obsidian as an AppImage. I keep at least one previous version available and usually run a symlink to the version I want. Redownloading has not helped; launching the app directly (no symlink) has not helped; disabling plugins has not helped; going back to the 1.3.7 installer gives immediate relief!!
The bug is therefore NOT Windows nor Windows unique peripheral helpers but an Obsidian bug related to the installer and not the installed version (my version is 1.4.16, it is only the installer that is out of date).